gauntlet-cswimr-plugins/flake.nix
cswimr 4bc006d97f
Some checks failed
Actions / Lint Plugins (push) Failing after 13s
Actions / Build Plugins (push) Failing after 15s
switch to yarn, add prettier-eslint, update dependencies
2024-12-22 12:11:24 -05:00

55 lines
1.3 KiB
Nix

{
inputs = {
nixpkgs.url = "github:cachix/devenv-nixpkgs/rolling";
systems.url = "github:nix-systems/default";
devenv.url = "github:cachix/devenv";
devenv.inputs.nixpkgs.follows = "nixpkgs";
};
nixConfig = {
extra-trusted-public-keys = "devenv.cachix.org-1:w1cLUi8dv3hnoSPGAuibQv+f9TZLr6cv/Hm9XgU50cw=";
extra-substituters = "https://devenv.cachix.org";
};
outputs =
{
self,
nixpkgs,
devenv,
systems,
...
}@inputs:
let
forEachSystem = nixpkgs.lib.genAttrs (import systems);
in
{
packages = forEachSystem (system: {
devenv-up = self.devShells.${system}.default.config.procfileScript;
devenv-test = self.devShells.${system}.default.config.test;
});
devShells = forEachSystem (
system:
let
pkgs = nixpkgs.legacyPackages.${system};
in
{
default = devenv.lib.mkShell {
inherit inputs pkgs;
modules = [
{
# https://devenv.sh/reference/options/
languages.javascript = {
enable = true;
yarn = {
enable = true;
install.enable = true;
};
};
}
];
};
}
);
};
}